Friday, July 3, 2015

P390, SAC Interface ztex board and other work

In the late afternoon, we heard a loud crack as the power went out in our area. A large tree had cracked, fallen across high voltage lines and snapped them. Through most of the evening we heard chain saws and cranes working, then slept in the dark until power came on in the wee hours. Needless to say, it cut sort my work on the 1130 and related projects.


I brought over a different DOS/VS tape image but still get the wait state when I try to IPL the tape, which doesn't start up when I 'ready' the JCL deck in the card reader. Not sure what is happening but will keep investigating. I can see that the P390 has an interrupt pending for the running code, but it isn't enabled for interrupts I suspect. On the other hand, it is not a disabled wait state either.

I can just do this all under my vm/370, which should at least give me more useful status if it doesn't work properly. That is, once I can power this up again.


I received some new desoldering tips for my Pace station today, which should make removal of the newly damaged replacement op amp easier. I put in the new tip, switched on the desoldering station, and . . . nothing. The fuses were all good but when I flipped on the main switch, nothing worked.

I opened it up to check for presence of voltage, including to the main rocker switch that powers it on and off. While manipulating the connections to the switch to test voltages, suddenly it would light up for a few seconds and then go off. The pump motor tried to work while the light was on, which means this is a true power issue and not just the bulb in the switch.

There are times I have to hang on tight to my rationality, lest I believe there are malevolent spirits just waiting to toy with me like this. Why would it fail right at this moment? Putting aside the yoyo of my emotions, I spent a few minutes but then closed it up and put it aside. I was already near the cutoff for fooling around with the Pertec drive and its power supply issues; this pushed me over the edge. For the time being, both the Pertec and this desoldering station will fester in the corner while I work on other things.


Richard Stofer and I are still battling the Ztex board and Xilinx toolchain, trying to figure out why I am having the problem getting the board to autoboot from the flash. Richard has some ideas which I will investigate, plus I will look at setting up a second Xilinx system at a different revision level to see what happens.

It is all a bit mysterious. A version of the bitfile that he produced and loads successfully on his end will configure the fpga to work but won't autoboot from flash on my system. My version of the bitfile loads and autoboots just fine on his end.

I was downloading the latest version of the Ztex SDK when the power went out.

No comments:

Post a Comment